After downloading large # of mails, Gmail POP downloads only one message at a time


I have configured Thunderbird to download emails from my Gmail account. Essentially, this is back up of my Gmail account. In Gmail settings, I enabled POP download from the date of account creation.

Within a few days, Thunderbird downloaded all the mails from the date of account creation (back in 2004.) When it reached the date from early this year, the downloading slowed down dramatically. Earlier, it used to download 300-600 mails in every fetch request. It now download only one message at a time. At this rate, my mails will take forever to download.

One of the oft-repeated solution to this problem is to disable "Leave Message On Server" option. But, this means, the messages from my Gmail account will vanish and my local copy is no longer a back up copy.

How do I download my mailbox from Gmail at the rate of few tens, if not hundreds, of messages in every fetch request?

Best Answer

Another thread on Gmail forum has the correct solution.

I resolved this issue as well by following what ant0nis did. Uncheck "Leave messages on the server" in Thunderbird, but LEAVE "When messages are accessed with POP:" to the setting "Keep Gmail's copy in Inbox"

GMail's setting needs be "Mail Settings" -> "Forwarding and POP/IMAP" -> "POP Download" -> "2. When messages are accessed with POP" -> "Keep Gmail's Copy in the Inbox". This setting ensures that the mails don't get deleted from your account even if they are downloaded from a POP email client.

Related Question