MacOS – My native mac apps are not connecting to the internet, but Google Chrome does and works correctly. Why is this

macbook promacosNetwork

A few days ago all the native apps on my OSX 10.10.4 MacBook Pro stopped connecting to the internet. This seemed to happen out of the blue, and I am not sure what caused this issue. Strangely, Google Chrome seems to work just fine, when even Terminal cannot connect. Here's a summary of what I've tried so far:

On the Terminal

  • ping google.com: ping: cannot resolve google.com: Unknown host
  • ping 8.8.8.8: 5 packets transmitted, 5 packets received, 0.0% packet loss
  • curl google.com: curl: (6) Couldn't resolve host 'google.com'
  • curl 8.8.8.8: curl: (7) Failed to connect to 8.8.8.8 port 80: Operation timed
  • ssh {servername} : ssh: Could not resolve hostname {servername}: nodename nor servname provided, or not known
  • nslookup google.com: This works correctly, but the response is lengthy so I won't post it.
  • dig google.com: This works correctly, but the response is lengthy so I won't post it.

So, to me, this seems like a DNS issue in that google.com is not resolved, but there is something else going on as well because curl 8.8.8.8 fails as well. Strangely though both nslookup and dig are working as expected.

I have also tried running these commands to reset DNS

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

Other things

  • I have restarted in Safe Mode, but this gave the same results.
  • I have also made sure that there are no proxy setting active.
  • I have tried a number of different Wifi locations. The wifi
    connects, but native apps do not have internet access.
  • I performed these test on both Wifi and a wired connection and
    observed the same results.
  • I removed and re-added the Wifi connection.
  • I restarted my computer many times.
  • There is no firewall.
  • I planned to install the newest OSX in hope that it would recover the
    computer, but I cannot connect to the App Store.
  • I created a new user account and performed these same tests but observed the same results.

Does anyone have any idea what could be happening? Any help is greatly appreciated!

EDIT

As requested by @willWorkForCookies, my resolv.conf file is actually a sym link. The original is located here: /private/var/run/resolv.conf

Here is my resolv.conf file:

$ cat /etc/resolv.conf 
#
# Mac OS X Notice
#
# This file is not used by the host name and address resolution
# or the DNS query routing mechanisms used by most processes on
# this Mac OS X system.
#
# This file is automatically generated.
#
domain hsd1.mi.comcast.net.
nameserver 75.75.76.76
nameserver 75.75.75.75
nameserver 2001:558:feed::2
nameserver 2001:558:feed::1

Using the following command to flush DNS had no affect:

sudo dscacheutil -flushcache sudo killall -HUP mDNSResponder

Best Answer

For me, the issue was a missing library file: "libgcc_s.1.dylib" which should have been located in "/usr/local/lib". Specifically, when trying to run mDNSResponder from the terminal, it was throwing a file not found error and reported this file as missing.

For others who are facing this issue, I would suggest trying to start mDNSResponder from the terminal by typing "mDNSResponder" into the terminal. It may report a missing library file.

I was not aware of how I could re-build this library, so I resorted to re-installing OSX from the recovery drive. This took about 5 hours, but all my files remained in place, along with my applications and the majority of my OSX settings.

Everything appears to be working correctly now =)