MacOS – How to create a bootable Ubuntu USB stick using OS X 10.10.2

bootable-diskmacbook promacosunix

I have downloaded the ubuntu-14.04.2-desktop-amd64.iso. How do I create a bootable Ubuntu USB stick using my Macbook Air which is running OS X 10.10.2? I cannot create a bootable CD, since the Air is designed without the optical drive.

Best Answer

Follow these steps to create an .img file from the .iso file you have, and then copy to the USB stick. This will also change the filesystem that is on the USB to make it bootable.

  1. Open the Terminal Application.
  2. Type command to convert the .iso file to .img using the convert option.

    hdiutil convert -format UDRW -o /path/to/target.img /path/to/ubuntu.iso

  3. Insert your flash media.

  4. Type command to determine the device node assigned to your flash media (e.g. /dev/disk2).

    diskutil list

  5. Type command to unmount the flash (replace N with the disk number from the last command; in the previous example, N would be 2).

    diskutil unmountDisk /dev/diskN

  6. Type DD command (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img). Prepend the device path with "r" for the raw path which is much faster than without the "r".

    sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m

    Note: your file might also be called downloaded.img.dmg. That's okay.

  7. Type command to eject the flash drive.

    diskutil eject /dev/diskN

  8. Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick as the boot disk.