macOS – How to Remove a Sound Output Device Created by an Application

audiocatalinamacmacbook promidi

On my mid 2012 MBP running macOS 10.15.1 (Catalina) I had an application create a sound output device. I deleted the application in finder by moving it to the trash. I know this method doesn't uninstall any dependencies or extra things the application might have installed which is why I'm having this issue. I went into the Audio MIDI Setup, but the (-) symbol is greyed out for the output, which is named AudioJingle. How would I go about uninstalling this output device?

Best Answer

Posting here for reference if you still have the problem and for other searching the answer was found at the Apple Community Site

Remove the following files:

  1. /Library/Audio/Plug-Ins/HAL/Audiojingle.driver
  2. /Library/LaunchDaemons/com.audiojinglex.soundtree.agent.plist
  3. /Library/LaunchAgents/com.audiojinglex.soundtree.agent.plist

Then restart coreaudiod using terminal sudo /bin/launchctl kill SIGTERM system/com.apple.audio.coreaudiod || /usr/bin/killall coreaudiod

or use the following script it does the same thing (I personally did it manually)

#!/bin/bash

# remove driver
DRIVER_NAME="Audiojingle.driver"
DRIVER_INSTALL_PATH="/Library/Audio/Plug-Ins/HAL/${DRIVER_NAME}"
if [  -d "${DRIVER_INSTALL_PATH}" ]; then
    /bin/rm -rf "${DRIVER_INSTALL_PATH}" || exit 1
fi

# remove helper plist

LAUNCHD_PLIST_INSTALL_PATH="/Library/LaunchDaemons"
LAUNCHD_PLIST_INSTALL_PATH_BACKUP="/Library/LaunchAgents"
LAUNCHD_PLIST_FILENAME="com.audiojinglex.soundtree.agent.plist"
LAUNCHD_PLIST="${LAUNCHD_PLIST_INSTALL_PATH}/${LAUNCHD_PLIST_FILENAME}"
LAUNCHD_PLIST_BACKUP="${LAUNCHD_PLIST_INSTALL_PATH_BACKUP}/${LAUNCHD_PLIST_FILENAME}"

# romove the plist.
if [ -e "${LAUNCHD_PLIST}" ]; then
    /bin/rm -f "${LAUNCHD_PLIST}"
fi

if [ -e "${LAUNCHD_PLIST_BACKUP}" ]; then
    /bin/rm -f "${LAUNCHD_PLIST_BACKUP}"
fi

#/usr/bin/killall -u "_coreaudiod" "coreaudiod"
/bin/launchctl kill SIGTERM system/com.apple.audio.coreaudiod || /usr/bin/killall coreaudiod

echo "restart coreaudio"

sleep 2